Wave Music Home
ReleasesCommunityYour OrderWave Music
ArtistsEventsDJ MixesShop

Wave Music Home


Home
About Us
Labels
Distributed Labels
Links




Search


Adv. Search



Subscribe


Email






Go Back   Wave Music Community Board > Tech Talk for Gearheads

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 04-20-2005, 10:08 AM
teker teker is offline
Registered User
 
Join Date: Dec 1969
Posts: 54
Crown DC-300

Hello all
I have this vintage amp and recently it started to clip even at low volumes. Both channels are distorting. At first this used to happen when I first turned on the amp and then after warming up it used dissappear. Now it does not. What might be wrong? And do you guys can recommend a repair shop in Manhattan so I could take this.
Reply With Quote
  #2  
Old 04-20-2005, 10:30 AM
pbellsound pbellsound is offline
Registered User
 
Join Date: Dec 1969
Location: NEW YORK CITY
Posts: 652
Contact the good folks at DBM. 212 629 0326

http://www.dbmproaudio.com/

Good luck!
Paul Bell
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:34 PM.


Powered by vBulletin Version 3.0.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
2006 Wave Music


© Wave Entertainment Group, Inc.